PDA

View Full Version : Lost my beginning red cards


jordan
01-31-2007, 07:55 PM
I've had two chars now lose the beginning red cards. Diplomacy is completely broken without them. Anyone else?

Slyde_Rule
01-31-2007, 08:14 PM
By "lose" do you mean that you had them, and were able to use them and then the disappeared ?

Once you receive them into your inventory, and right-click them, they should go to your Dip abilities page where they can't be deleted.

To have it happen twice seems like an unlikely coincidence ...

jordan
01-31-2007, 08:17 PM
By "lose" do you mean that you had them, and were able to use them and then the disappeared ?


Yes, I had them and then they went away into the ether. Not available in my strategy/dip page.

Mirra
01-31-2007, 09:21 PM
Yes, I had them and then they went away into the ether. Not available in my strategy/dip page.

That happened to me with two different characters during beta. It happens.:mad:

Ferrer
01-31-2007, 11:25 PM
That happened to me with two different characters during beta. It happens.:mad:

It also could be a diplo AOE buff. Some civic diplomacy rewards come in the form of diplo cards and they depend on the buff being active.

Mirra
02-01-2007, 11:33 AM
It also could be a diplo AOE buff. Some civic diplomacy rewards come in the form of diplo cards and they depend on the buff being active.

No it wasn't. For me, it was the aggressive statement card. It is an actual bug. Luckily I have not had it happen since beta. All you can do is /bug it.