PDA

View Full Version : Khal Diplo quest is bugged for some?


Paull
02-01-2007, 09:15 PM
One of the two quests the Qaliathari diplomacy trainer offers leads to a quest called "What is truly being worshipped?" that appears to be bugged for some. The quest requires you to speak to three of the priests in the Temple of Sea and Sand in Khal and convince them to stop taking bribes. After accepting the quest I try to speak to them but the only option available is civic diplomacy. I've spoken to two people and one of them cleared it fine and the other was having the same problem as me. Has anyone else encountered this problem and found some way past it?

Aluna
02-02-2007, 05:33 AM
Same problem for me, the Civ. diplomacy tutorial quest bugged on me also for some reason. Worst is its affecting all my chars.

Paull
02-02-2007, 05:59 AM
I haven't tried a new character yet. The solutions I have tried are relogging, abandoning the quest and restarting it, and getting clergy presence. I play a Qalathari bard. If anyone can think of anything else to try, please let me know.

Edit: I've made a new Qalathari character and they had the same problem. I also tried a new Mordabi character but they have different quests.

Edit: Both my male and female attempts to pass the test have failed now too. I'm at a loss now.